Problem compiling cmemk with GIT kernel

Bobby Buck bobbybuckpasquale at hotmail.com
Sun Mar 11 09:10:09 CST 2007


Building cmemk.ko and dsplinkk.ko for the GIT kernel is not a 
straight-forward task. Two weeks ago, I went through exactly what you're 
going through now. After a few frustrating days attempting to build these 
modules, I gave up and decided to revert to the montavista kernel for the 
time being.

Please see a post entitled "Building cmemk.ko and dsplinkk.ko" which I 
posted on the 28th of February 2007. Kevin's advice and patch files were 
extremely helpful, and will probably solve your current problems, if you are 
confident enough at patching/hacking source files.

Good luck,

Bobby



>From: Andy Ngo <ndno72-davinci at yahoo.com>
>To: "davinci-linux-open-source @linux.davincidsp.com" 
><davinci-linux-open-source at linux.davincidsp.com>
>Subject: Problem compiling cmemk with GIT kernel
>Date: Sun, 11 Mar 2007 00:22:58 -0800 (PST)
>
>Hi,
>
>I recently switched from the Montavista kernel to the GIT kernel.  I need 
>to rebuild cmemk.ko and dsplinkk.ko
>with the GIT kernel.  When I build cmemk.ko, I get undefined references to 
>class_simple_*:
>
># make
>make -C 
>/opt/montavista/pro/devkit/lsp/ti-davinci_evm-arm_v5t_le/linux-davinci-2.6 
>M=`pwd` ARCH=arm 
>CROSS_COMPILE=/opt/montavista/pro/devkit/arm/v5t_le/bin/arm_v5t_le- \
>         EXTRA_CFLAGS="-DUSE_UDEV=1 -DMAX_POOLS=128" modules
>make[1]: Entering directory 
>`/opt/montavista/pro/devkit/lsp/ti-davinci_evm-arm_v5t_le/linux-davinci-2.6'
>   CC [M]  
>/opt/dvevm_1_10/cmem_1_01/packages/ti/sdo/linuxutils/cmem/src/module/cmemk.o
>/opt/dvevm_1_10/cmem_1_01/packages/ti/sdo/linuxutils/cmem/src/module/cmemk.c: 
>In function `cmem_init':
>/opt/dvevm_1_10/cmem_1_01/packages/ti/sdo/linuxutils/cmem/src/module/cmemk.c:581: 
>warning: implicit declaration of function `class_simple_create'
>/opt/dvevm_1_10/cmem_1_01/packages/ti/sdo/linuxutils/cmem/src/module/cmemk.c:581: 
>warning: assignment makes pointer from integer without a cast
>/opt/dvevm_1_10/cmem_1_01/packages/ti/sdo/linuxutils/cmem/src/module/cmemk.c:587: 
>warning: implicit declaration of function `class_simple_device_add'
>/opt/dvevm_1_10/cmem_1_01/packages/ti/sdo/linuxutils/cmem/src/module/cmemk.c: 
>In function `cmem_exit':
>/opt/dvevm_1_10/cmem_1_01/packages/ti/sdo/linuxutils/cmem/src/module/cmemk.c:686: 
>warning: implicit declaration of function `class_simple_device_remove'
>/opt/dvevm_1_10/cmem_1_01/packages/ti/sdo/linuxutils/cmem/src/module/cmemk.c:689: 
>warning: implicit declaration of function `class_simple_destroy'
>   Building modules, stage 2.
>   MODPOST 1 modules
>WARNING: "class_simple_destroy" 
>[/opt/dvevm_1_10/cmem_1_01/packages/ti/sdo/linuxutils/cmem/src/module/cmemk.ko] 
>undefined!
>WARNING: "class_simple_device_remove" 
>[/opt/dvevm_1_10/cmem_1_01/packages/ti/sdo/linuxutils/cmem/src/module/cmemk.ko] 
>undefined!
>WARNING: "class_simple_device_add" 
>[/opt/dvevm_1_10/cmem_1_01/packages/ti/sdo/linuxutils/cmem/src/module/cmemk.ko] 
>undefined!
>WARNING: "class_simple_create" 
>[/opt/dvevm_1_10/cmem_1_01/packages/ti/sdo/linuxutils/cmem/src/module/cmemk.ko] 
>undefined!
>   CC      
>/opt/dvevm_1_10/cmem_1_01/packages/ti/sdo/linuxutils/cmem/src/module/cmemk.mod.o
>   LD [M]  
>/opt/dvevm_1_10/cmem_1_01/packages/ti/sdo/linuxutils/cmem/src/module/cmemk.ko
>make[1]: Leaving directory 
>`/opt/montavista/pro/devkit/lsp/ti-davinci_evm-arm_v5t_le/linux-davinci-2.6'
>
>
>When I load cmemk.ko, I get errors for those undefined references:
>
># insmod cmemk.ko phys_start=0x87800000 phys_end=0x88000000 
>pools=1x3145728,3x829440,1x61440,1x10240
>cmemk: module license '(c) Texas Instruments' taints kernel.
>cmemk: Unknown symbol class_simple_device_add
>cmemk: Unknown symbol class_simple_destroy
>cmemk: Unknown symbol class_simple_device_remove
>cmemk: Unknown symbol class_simple_create
>insmod: cannot insert `cmemk.ko': Unknown symbol in module (-1): No such 
>file or directory
>
>I'm using the latest GIT kernel (2.6.20-omap1) and dvevm 1.10.  I haven't 
>tried compiling dsplinkk.ko yet.  Anyone has this same problem?
>Am I doing something wrong?  Thanks.
>
>Regards,
>Andy
>
>
>


>_______________________________________________
>Davinci-linux-open-source mailing list
>Davinci-linux-open-source at linux.davincidsp.com
>http://linux.davincidsp.com/mailman/listinfo/davinci-linux-open-source

_________________________________________________________________
Advertisement: It's simple! Sell your car for just $20 at carsales.com.au  
http://a.ninemsn.com.au/b.aspx?URL=http%3A%2F%2Fsecure%2Dau%2Eimrworldwide%2Ecom%2Fcgi%2Dbin%2Fa%2Fci%5F450304%2Fet%5F2%2Fcg%5F801577%2Fpi%5F1005244%2Fai%5F838588&_t=757768878&_r=endtext_simple&_m=EXT



More information about the Davinci-linux-open-source mailing list